Delays in delivering updates to connectors
Incident Report for hull
Resolved
This incident has been resolved.
Posted May 10, 2019 - 15:53 EDT
Investigating
We are currently investigating this issue.
Posted May 10, 2019 - 11:38 EDT
This incident affected: Hull Core Platform (Hull Background Worker).